Superb quality and spec AB-Com PULSe 4K SE. Crazy offer! Only £99! FREE UK DELIVERY! 4K UHD, Enigma 2, Multiboot 4 images & more!...
Superb quality and spec AB-Com PULSe 4K Rev II Twin Satellite tuner only £149! FREE UK DELIVERY! 4K UHD, Enigma 2, SATA HDD facility, Multiboot 4 images & more!...

[Formuler F1] GUI Freeze and hang

chulann

New member
Joined
Aug 2, 2022
Messages
13
Reaction score
0
Points
0
I upgraded today from a late OpenVIX 5 (think it was 5.8). I actually forgot to backup the settings so did an install from clean.

I am getting frequent GUI hangs (16 reboots in 3 hours). When I change channels, the information box will frequently stay there - any further attempts at change will reduce the video to a box and the information box will stay there. Sometimes I can change channel once and then I can't do any more. In all cases, the video stream keeps playing.

I get a similar situation when playing previous recordings - if I try and fast forward, it will lock. Sometimes it will allow me to play and then commit no more commands.

I have managed to get limited logs. I attach a condensed version because the original had 53,000 entries of "[huffman] Error. Cannot decode Huffman data" and another 20,000 of "[convertDVBUTF8] reserved 0". While I can SSH in, init 4 and then init 3 doesn't do anything.

View attachment Enigma2_debug_2022-08-02_23-03-05_condensed.log

I don't have an internal HDD - so the EPG is on the internal flash. I have tried to remove as many plugins as possible - I do still have AutoBouquets E2, Picture Player, OpenWebif and IMDb setup - I didn't install these so wondering now if some elements have hung on from the previous installation? Does flashing wipe all config? I have it NTP syncing from pool.ntp.org and use AutoBouquets.

I do have a slightly unusual mount - I have a ZFS export mounted to /beast and then link both /e2 and /media/hdd to /beast/enigma2 on the F1 box.

Any help or suggestions gratefully received.

Regards,
 
I upgraded today from a late OpenVIX 5 (think it was 5.8). I actually forgot to backup the settings so did an install from clean.

I am getting frequent GUI hangs (16 reboots in 3 hours). When I change channels, the information box will frequently stay there - any further attempts at change will reduce the video to a box and the information box will stay there. Sometimes I can change channel once and then I can't do any more. In all cases, the video stream keeps playing.

I get a similar situation when playing previous recordings - if I try and fast forward, it will lock. Sometimes it will allow me to play and then commit no more commands.

I have managed to get limited logs. I attach a condensed version because the original had 53,000 entries of "[huffman] Error. Cannot decode Huffman data" and another 20,000 of "[convertDVBUTF8] reserved 0". While I can SSH in, init 4 and then init 3 doesn't do anything.

View attachment 64149

I don't have an internal HDD - so the EPG is on the internal flash. I have tried to remove as many plugins as possible - I do still have AutoBouquets E2, Picture Player, OpenWebif and IMDb setup - I didn't install these so wondering now if some elements have hung on from the previous installation? Does flashing wipe all config? I have it NTP syncing from pool.ntp.org and use AutoBouquets.

I do have a slightly unusual mount - I have a ZFS export mounted to /beast and then link both /e2 and /media/hdd to /beast/enigma2 on the F1 box.

Any help or suggestions gratefully received.

Regards,
Need to see 1st log after a reboot and potentially 2nd log
 
you have timeshift enabled but HDD is not mounted, so fails no space and beast (whatever that is)

< [eDVBServicePlay] timeshift not enough diskspace for timeshift! (less than 1GB)

< 57.2027> command ['mkdir -p /media/hdd', 'sleep 2', 'mount 172.30.1.2:/beast']
< 57.2032> [Console] command: mkdir -p /media/hdd


< 59.5227> [Avahi] watch activated: 0x1
< 59.5238> [Console] finished: mkdir -p /media/hdd
< 59.5244> [Console][eBatch] retval=0, cmds=['sleep 2', 'mount 172.30.1.2:/beast'] cmds left=2, data:
< 59.5245>
< 59.5249> [Console] command: sleep 2
< 59.5252> [eConsoleAppContainer] Starting /bin/sh

< 61.5933> [Console] finished: sleep 2
< 61.5936> [Console][eBatch] retval=0, cmds=['mount 172.30.1.2:/beast'] cmds left=1, data:
< 61.5938>
< 61.5942> [Console] command: mount 172.30.1.2:/beast
< 61.5945> [eConsoleAppContainer] Starting /bin/sh
< 61.6647> [Console] finished: mount 172.30.1.2:/beast
< 61.6651> [Console][eBatch] retval=255, cmds=[] cmds left=0, data:
mount: mounting 172.30.1.2:/beast on /beast failed: Device or resource busy
< 61.6653> fails to mount
 
Last edited:
Thanks for looking at it.

/beast is my NFS mounted ZFS partition (about 15TB). Problem is, if I go into Menu -> Setup -> Recordings, Playback & Timeshift -> Timeshift, I can't get past the first option of selecting a folder. Any folder I choose returns with "Directory 'XYZ' not valid. Partition must be ext or nfs. Please select an acceptable directory" - and that's on any NFS or local folder (if I select a local folder, I get an additional option first of "Not enough space, are you sure you want to do this"). I get a similar error in trying to set the folder for Recordings & Playback.

I think timeshift is disabled because "Automatically start timeshift after" is set to disabled.

Ideally, I'd like to set the timeshift to /beast/enigma2/timeshift but if it's causing the problem, I'd like to ensure it's disabled.

Thanks!
 
Thanks for looking at it.

/beast is my NFS mounted ZFS partition (about 15TB). Problem is, if I go into Menu -> Setup -> Recordings, Playback & Timeshift -> Timeshift, I can't get past the first option of selecting a folder. Any folder I choose returns with "Directory 'XYZ' not valid. Partition must be ext or nfs. Please select an acceptable directory" - and that's on any NFS or local folder (if I select a local folder, I get an additional option first of "Not enough space, are you sure you want to do this"). I get a similar error in trying to set the folder for Recordings & Playback.

I think timeshift is disabled because "Automatically start timeshift after" is set to disabled.

Ideally, I'd like to set the timeshift to /beast/enigma2/timeshift but if it's causing the problem, I'd like to ensure it's disabled.

Thanks!

Have you installed nfs drivers?
 
The NFS share mounts properly (once I edit /etc/fstab and specify NFS version 4 as an option)
 
Thanks for looking at it.

/beast is my NFS mounted ZFS partition (about 15TB). Problem is, if I go into Menu -> Setup -> Recordings, Playback & Timeshift -> Timeshift, I can't get past the first option of selecting a folder. Any folder I choose returns with "Directory 'XYZ' not valid. Partition must be ext or nfs. Please select an acceptable directory" - and that's on any NFS or local folder (if I select a local folder, I get an additional option first of "Not enough space, are you sure you want to do this"). I get a similar error in trying to set the folder for Recordings & Playback.

I think timeshift is disabled because "Automatically start timeshift after" is set to disabled.

Ideally, I'd like to set the timeshift to /beast/enigma2/timeshift but if it's causing the problem, I'd like to ensure it's disabled.

Thanks!
What local folder?

Please get debug of trying to set up a recordings or timeshift location.
 
Thanks for your help. I ran out of time in the last new weeks so couldn't get the debug logs.

I have upgraded to 6 009 and it seems to have solved the problems! (There's a niggle that playbacks don't necessarily respond to the play button during fast forward even though the red light on the front indicates remote signals, but that's for another post)
 

OpenViX Feeds Status

Back
Top