enf70
New member
- Joined
- May 3, 2014
- Messages
- 13
- Reaction score
- 0
- Points
- 0
I think user-level security (security = user in smb.conf) is broken in samba 3.0.37 on Vu+.
Any user apart from the guest user fails to authenticate and the error message in smb.log is something like: "Failed to set gid privileges..."
I have recompiled samba with the following line in "samba_3.0.37.bb":
CFLAGS += "-DUSE_SETREUID=1"
and now user-level security seems to be working fine.
I though some people might be interested in this.
Any user apart from the guest user fails to authenticate and the error message in smb.log is something like: "Failed to set gid privileges..."
I have recompiled samba with the following line in "samba_3.0.37.bb":
CFLAGS += "-DUSE_SETREUID=1"
and now user-level security seems to be working fine.
I though some people might be interested in this.