Only if the server is a single tuner box.
There really should be a check for network up, e.g. ping the server.
Hi Huevos,
Thanks for the update in 6.4.010 to try to address this. It makes the client box usable after boot.
However, there are some issues.
Firstly, when the WiFi-connected client box fails to connect on first attempt it does the following:
1. 3D Vix logo rotates at top-left, then the bar which shows the current channel shows at the bottom of the screen for a few seconds. During this time it looks like you can try and change the channel but it will not work.
2. The 3D Vix logo then comes back and rotates again at the top-left (I assume this is the first re-attempt at running the ChannelsImporter). When the Vix logo has finished rotating, the bar showing the channel at the bottom reappears.
The main problem here is that the channel does not start to automatically stream. To start streaming a channel, you need to change the channel - this time it works.
How I would expect the boot process to work from a user point-of-view instead:
1. Turn on the box, and see Vix logo rotating.
2. No end of logo rotation and no visible channel bar at bottom until a full connection has been established (so the user is not confused and think the boot has completed, and then tries to change the channel when it won't work)
3. Once fully booted and connected, the last viewed channel should start to stream automatically.
Secondly, the whole boot process is very
slow when there is an initial connection failure. I had a brief look at the code and don't fully understand it - there seems to be a delay (not sure how long) between each attempt and only 5 attempts. Instead, to speed this up, could we not ping say every second and then time-out after a minute? Is testing a full FTP connection necessary?
Thanks again for your time and work,
Paul