Superb quality and spec AB-Com PULSe 4K SE. Crazy offer! Only £99! FREE UK DELIVERY! 4K UHD, Enigma 2, Multiboot 4 images & more!...
Superb quality and spec AB-Com PULSe 4K Rev II Twin Satellite tuner only £149! FREE UK DELIVERY! 4K UHD, Enigma 2, SATA HDD facility, Multiboot 4 images & more!...

[Zgemma H7] OpenTV EPG Downloader

goo

Member
Joined
Apr 12, 2022
Messages
44
Reaction score
0
Points
6
Since Openvix 6.6 update, both Gigablue Quad 4K and Zgemma H7C fail to return to standby after OpenTV EPG Updater finishes.
It goes to to full On mode instead.
I tried it with 'Schedule return to Deep Stanby' set to 'No' but it did exactly the same.
 
No biggie by any means, but both boxes fail to return to Deep Standby again after update to OpenVix 6.7.001. Just go to standby.
 
No biggie by any means, but both boxes fail to return to Deep Standby again after update to OpenVix 6.7.001. Just go to standby.

How are you running the OpenTV updater? Is the EPG update actually running? Do you have a debug log file by any chance?
 
No biggie by any means, but both boxes fail to return to Deep Standby again after update to OpenVix 6.7.001. Just go to standby.

Although not curing the problem of the box not returning to deep standby you can use a power timer to get the box to go to deep standby if the box is in standby for, say, 10 minutes. This is assuming that the box is not running a background task where it needs to be in standby - or maybe a recording.

Example power timer can be found at
https://www.world-of-satellite.com/showthread.php?63922-startup-to-standby#6
with a small correction at
https://www.world-of-satellite.com/showthread.php?63922-startup-to-standby#8
 
Last edited:
Good suggestion - @adm. I was trying to determine if the OP was actually using a PowerTimer or the in-built "boot from standby" scheduler in the OpenTV zapper package.
 
Don't have debug log, but yes the EPG does seem to update OK using the OpenTV EPG downloader to update in the morning roughly every other day.
Also noticed the GBQuad (not tried Zgemma) does not go back to deep standby after timers that have started from deep standby have completed.
There's a "Wake up to standby" option in the System/Customise menu I never noticed before. Could this be confusing it?
I'm using the Magic-FHD skin.
 
Attached debug logs.

GBQUAD4K is today's when it failed to return to deep standby after OpenTV EPG downloader had updated.

H7 is Zgemma H7C from yesterday when it had booted to standby by itself.
I had disabled OpenTV EPG downloader altogether a few days ago and there are no timers set on it.
I have found it in standby in the morning a few times when I'm sure it was in deep standby the night before.View attachment GBQUAD4K_Enigma2_debug_2025-02-17_01-24-15.logView attachment H7_Enigma2_debug_2025-02-16_10-01-47.log
 
@goo - according to the Zgemma log it booted because you have a scheduled start set for OpenTVZapper. It set the next scheduled boot up for Thursday 20th Feb at 09:00:00. Are you sure you don't have the schedule enabled in the OpenTV loader? Is it possible that you have disabled the OpenTV EPG reader in the EPG settings instead? This would disable the automatic population of the EPG when tuned to the SKY transponder. What the OpenTV zapper plug-in does is tune to the SKY transponder, either every x hours or on a schedule that you can set. The individual EPG readers (like Freesat and OpenTV) are configured in the EPG settings menu - press menu on your remote, then select Setup/EPG/Settings. The OpenTV zapper is configured from the Setup/EPG/OpenTV EPG downloader. The EPG type reader for OpenTV must be set to enabled for the zapper (downloader) to actually work. You can actually manually tune to the SKY EPG channel manually (it's towards the end of your SKY bouquet) and leave it tuned for about three minutes and it will populate the EPG. This is basically what the zapper plug-in does.
 
@goo - your GB Quad log looks a bit odd in regard to the time setting. It looks like the system time is not being set correctly from boot. Normally, the system time is updated during boot by a call to an NTP server if available, then afterwards from NTP or from the tuned transponder. Your network settings look like they are being set manually rather than by DHCP. Do you have good internet access from the receiver? Also, it is attempting but failing to tune BBC at startup. You seem to have a unicable LNB configured, but I'm not familiar with those. Again, it looks like the OpenTV zapper plugin is operating some form of schedule - this time set to 09:15:00, but the receiver thought it was 01:24 today when it started up, when that was probably the time stored when it last shut down. Check your EPG settings for both the EPG type and for the OpenTV zapper on this box and confirm that it has good internet access. Maybe try setting DHCP temporarily? If you want to allocate specific IP addresses maybe set the router to allocate them based on the receiver MAC addresses.
 
I haven't changed anything, just updated to 6.7 from 6.6. Both boxes went to standby and deep standby when they were supposed to before the update.
Yes, the OpenTV EPG downloader is set to 9:15 am roughly every other day, and works fine, EXCEPT it fails to go back to deep standby afterwards.
Time setting on both boxes is set from transponder because I found if I set it to internet time and I lose my router temporarily for some reason they lose time setting and fail to boot up to record timers.
I set network addresses manually as network addresses are pinned to Quick Access in Windows Explorer.

Noticed Zgemma boots are beacause it is still trying to run OpenTV EPG Downloader to times set in schedule, even though it is disabled. As per possible bug in thread above this.

Still doesn't go back to deep standby though.
 

OpenViX Feeds Status

Back
Top