Superb quality and spec AB-Com PULSe 4K SE. Crazy offer! Only £129! FREE UK DELIVERY! 4K UHD, Enigma 2, Multiboot 4 images & more!...
Superb quality and spec AB-Com PULSe 4K Rev II Twin Satellite tuner only £179! FREE UK DELIVERY! 4K UHD, Enigma 2, SATA HDD facility, Multiboot 4 images & more!...

Filesystem Error: fsck

  • Thread starter Thread starter Richy-G
  • Start date Start date
I'm not sure , I remember formatting the hard drive when got it not sure which system though it was quite a while back then just initialized it and has been working fine up until this.

I'd say easiest thing to is to re-initialize connected to the receiver (you will loose all data). Menu > Setup > System > Harddisk.
 
Did you format it with your box or a computer ? Anyway we can see if the disk has reported errors (if it is a hardware failure) by installing smartmontools:
Code:
opkg install smartmontools
smartctl -a /dev/sda

Post the output of 'smartctl -a /dev/sda'

And you might aswell try to mount the file system with 'mount -t ext3 /dev/sda1 /media/hdd' or if that fails 'mount -t ext4 /dev/sda1 /media/hdd'

Below is output of smartctl -a /dev/sda , Afterwords I tried to mount with both options you gave me and both failed


root@vuduo:~# smartctl -a /dev/sda
smartctl 5.39.1 2010-01-28 r3054 [mipsel-oe-linux-gnu] (local build)
Copyright (C) 2002-10 by Bruce Allen, http://smartmontools.sourceforge.net

=== START OF INFORMATION SECTION ===
Device Model: SAMSUNG HD103SJ
Serial Number: S246JD2ZB04668
Firmware Version: 1AJ10001
User Capacity: 1,000,203,804,160 bytes
Device is: Not in smartctl database [for details use: -P showall]
ATA Version is: 8
ATA Standard is: ATA-8-ACS revision 6
Local Time is: Fri Mar 2 11:15:37 2012 GMT
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED

General SMART Values:
Offline data collection status: (0x00) Offline data collection activity
was never started.
Auto Offline Data Collection: Disabled.
Self-test execution status: ( 0) The previous self-test routine completed
without error or no self-test has ever
been run.
Total time to complete Offline
data collection: (9000) seconds.
Offline data collection
capabilities: (0x5b) SMART execute Offline immediate.
Auto Offline data collection on/off supp
ort.
Suspend Offline collection upon new
command.
Offline surface scan supported.
Self-test supported.
No Conveyance Self-test supported.
Selective Self-test supported.
SMART capabilities: (0x0003) Saves SMART data before entering
power-saving mode.
Supports SMART auto save timer.
Error logging capability: (0x01) Error logging supported.
General Purpose Logging supported.
Short self-test routine
recommended polling time: ( 2) minutes.
Extended self-test routine
recommended polling time: ( 150) minutes.
SCT capabilities: (0x003f) SCT Status supported.
SCT Feature Control supported.
SCT Data Table supported.

SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME FLAG VALUE WORST THRESH TYPE UPDATED WHEN_
FAILED RAW_VALUE
1 Raw_Read_Error_Rate 0x002f 100 100 051 Pre-fail Always -
11
2 Throughput_Performance 0x0026 252 252 000 Old_age Always -
0
3 Spin_Up_Time 0x0023 072 072 025 Pre-fail Always -
8774
4 Start_Stop_Count 0x0032 098 098 000 Old_age Always -
2249
5 Reallocated_Sector_Ct 0x0033 252 252 010 Pre-fail Always -
0
7 Seek_Error_Rate 0x002e 252 252 051 Old_age Always -
0
8 Seek_Time_Performance 0x0024 252 252 015 Old_age Offline -
0
9 Power_On_Hours 0x0032 100 100 000 Old_age Always -
5599
10 Spin_Retry_Count 0x0032 252 252 051 Old_age Always -
0
11 Calibration_Retry_Count 0x0032 252 252 000 Old_age Always -
0
12 Power_Cycle_Count 0x0032 100 100 000 Old_age Always -
215
191 G-Sense_Error_Rate 0x0022 252 252 000 Old_age Always -
0
192 Power-Off_Retract_Count 0x0022 252 252 000 Old_age Always -
0
194 Temperature_Celsius 0x0002 064 064 000 Old_age Always -
25 (Lifetime Min/Max 16/52)
195 Hardware_ECC_Recovered 0x003a 100 100 000 Old_age Always -
0
196 Reallocated_Event_Count 0x0032 252 252 000 Old_age Always -
0
197 Current_Pending_Sector 0x0032 252 252 000 Old_age Always -
0
198 Offline_Uncorrectable 0x0030 252 252 000 Old_age Offline -
0
199 UDMA_CRC_Error_Count 0x0036 200 200 000 Old_age Always -
0
200 Multi_Zone_Error_Rate 0x002a 100 100 000 Old_age Always -
0
223 Load_Retry_Count 0x0032 252 252 000 Old_age Always -
0
225 Load_Cycle_Count 0x0032 100 100 000 Old_age Always -
2308

SMART Error Log Version: 1
No Errors Logged

SMART Self-test log structure revision number 1
No self-tests have been logged. [To run self-tests, use: smartctl -t]


Note: selective self-test log revision number (0) not 1 implies that no selectiv
e self-test has ever been run
SMART Selective self-test log data structure revision number 0
Note: revision number not 1 implies that no selective self-test has ever been ru
n
SPAN MIN_LBA MAX_LBA CURRENT_TEST_STATUS
1 0 0 Completed [00% left] (0-65535)
2 0 0 Not_testing
3 0 0 Not_testing
4 0 0 Not_testing
5 0 0 Not_testing
Selective self-test flags (0x0):
After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.

root@vuduo:~#
 
Last edited by a moderator:
Well smartctl output looks good, the physical disk seems to be fine, you can free up the space used by that tool by uninstalling it (opkg remove smartmontools)

I would go for a reformat as Sicillian suggested, you will loose all data on the disk though. If it indeed is a NTFS filesystem on the disk, and you want to go through the trouble - connect it to a machine running windows and see if the builtin filecheck can repair it. If it can, save your precious data somewhere else and let the sat box reformat the disk as Sicillian suggested.
 
HDD error

My duo keeps crashing with HDD error.

I have 1tb Western Digital HDD which was working fine for last 3 days (when I set up my brand new box). The problem arose when I go into HDD direcotry to select playback the box crashes. Now all recordings are missing and EPG data wiped out. The following error message is showing: "Non existent Device. fsck.ext3. No such file on directory while trying to open dev/sda1"

I am still newbie and learning. Please, please inform how to fix this.

Thanks
 
1- If the box crashes, there is a crashreport. Please upload that.
2- Go to Menu -->setup --> ViX --> MountManager: what does it tell you about the HDD? A screenshot could help.
3- Go to the HDD via an FTP-client and see if the folder '/movie' exists. If not create it.
4- How did you initialise the HDD? You should have done that via Menu --> setup --> HDD --> initialise
 
1- If the box crashes, there is a crashreport. Please upload that.
2- Go to Menu -->setup --> ViX --> MountManager: what does it tell you about the HDD? A screenshot could help.
3- Go to the HDD via an FTP-client and see if the folder '/movie' exists. If not create it.
4- How did you initialise the HDD? You should have done that via Menu --> setup --> HDD --> initialise

The MountManager shows the following:

Hard Disc: WDC 10ZRX-00A; Size: 931GB; Device: dev/sda1; Mount:/media/hdd; Type:ext4 R/W

I have checked vai FTP and the folder movies does exists; it is under media/hdd/movies.

The HDD was intialised in the original image, 3 days ago, and worked fine until yesterday. The crash log from yesterday contained message "write error on recording. disk full" and "Cannont allocate memory"

I have since done a complete shut down and reboot and then the lost information appears incuding epg. However, when I select playback of recordings it crashes and restarts itself and then the EPG or recorded list does not appear.

I have not created recording paths. Do Ineed to create these and if so how do you do this. I flashed mu box using openvix-3.0.339, i did not use bootloader. Should I have used bootloader?

Aprreaciate your advice.
 
The MountManager shows the following:

Hard Disc: WDC 10ZRX-00A; Size: 931GB; Device: dev/sda1; Mount:/media/hdd; Type:ext4 R/W

I have checked vai FTP and the folder movies does exists; it is under media/hdd/movies.

The HDD was intialised in the original image, 3 days ago, and worked fine until yesterday. The crash log from yesterday contained message "write error on recording. disk full" and "Cannont allocate memory"

I have since done a complete shut down and reboot and then the lost information appears incuding epg. However, when I select playback of recordings it crashes and restarts itself and then the EPG or recorded list does not appear.

I have not created recording paths. Do Ineed to create these and if so how do you do this. I flashed mu box using openvix-3.0.339, i did not use bootloader. Should I have used bootloader?

Aprreaciate your advice.
1- If your system boots/worked OK, there's no need to flash a bootloader;
2- Although not the cause of your problem, initialising an HDD using OI has the huge disadvantage that Ext3 is being used. The fact that mountmanager states it to be Ext4 is wrong: it displays all Ext formats as Ext4. Please use a modern image (such as ViX) to initialise the HDD
3- Normally recordings settings do not have to be manipulated when an internal HDD is in use. But please have a look at it to see if it is set correct.
4- Can you post the outcome of the telnet commands 'df -h' and 'blkid'?
 
Will intialise the drive in Vix. However, before I do this I tried to update to Vix 3.0 378 (vai menu>setup>online update) but message said nothing to update. How do I update to latest 378 version of Vix

The outcome of the telnet commands 'df -h' and 'blkid' , is as follows:

Welcome to OpenViX for vuduo
openvix 3.0 vuduo


vuduo login: root
root@vuduo:~# blkid
/dev/sda1: UUID="e0949b23-c866-41fc-a8f2-4ea32162ba83" SEC_TYPE="ext2" TYPE="ext
3"
root@vuduo:~# df -h
Filesystem Size Used Available Use% Mounted on
ubi0:rootfs 102.1M 51.9M 50.3M 51% /
devtmpfs 67.5M 4.0K 67.4M 0% /dev
tmpfs 64.0K 0 64.0K 0% /media
/dev/sda1 931.2G 13.8G 917.4G 1% /media/hdd
tmpfs 67.6M 1.2M 66.4M 2% /var/volatile
root@vuduo:~#

Please let me know what I need to do to sort this problem with the HDD and how to update Vix image to latest 378.
Many Thanks
 
OK, the good news is that your output seems to be fine.
The bad news is that I now have no clue what can be wrong.

Update to 380 should be possible online.

For the HDD Ext4 is the best format, but this will not solve your problem. Or maybe it happens to do so......??
 
OK, the good news is that your output seems to be fine.
The bad news is that I now have no clue what can be wrong.

Update to 380 should be possible online.

For the HDD Ext4 is the best format, but this will not solve your problem. Or maybe it happens to do so......??

Thanks. How do I update to 380. When I select online software update (vai menu>setup>online update) message keeps coming saying nothing to update. Is there a manual file for 380 which I can use to upload vai USB or is there an easier way.

Also, I am searching for AutoBouquets 28.2 plug in feed to download, but can't seem to find it. Please let me know where this is located.
 
check the version you have on the box already in menu> information> about. then try again. also to install the autobouquets plugin from the feeds it's in menu> plugins> green to download > then look in the various sub sections there for it. or install the version manually from the forum but be aware that both versions are different and not compatible with each other, use one or the other not both.
 
check the version you have on the box already in menu> information> about. then try again. also to install the autobouquets plugin from the feeds it's in menu> plugins> green to download > then look in the various sub sections there for it. or install the version manually from the forum but be aware that both versions are different and not compatible with each other, use one or the other not both.

Looked in the sub sections but still can't seem to find autobouquets. Can you tell me which sub section.
 
Looked in the sub sections but still can't seem to find autobouquets. Can you tell me which sub section.

I'm at work at the moment and dont have access to a receiver to check. if you can list the various headings in the plugin feeds i can tell you that way.
 
I'm at work at the moment and dont have access to a receiver to check. if you can list the various headings in the plugin feeds i can tell you that way.

The sub sections are: drivers, dvb, extensions, picons, security, settings, skins, system plug ins, and Vix. I have searched but can't seem to find. Please let me know which sub section it should be in..
 
HDD Problems

I am still having problems withh Hard drive which is causing the box to crash when I try to access the HDD or hard disk menu. The last message showed it was not intialised i tried to intialise but it does not work. After the last crash the mount manger is showing the hdd unmounted when i try to mount using the colour button it fails to mount. When the drive was mounted the crash logs contained message "write error on recording. disk full" and "cannont allocate memory"

How can I fix the Hard Drive and mount it back to get it to work. The HDD is a new western digital 1tb installled three days ago and it was intialised in the original image without any problems. Help Please
 
The last message showed it was not intialised i tried to intialise but it does not work
What exactly does 'it does not work' mean?
You have to initialise the HDD. After starting the initialisation process you must allow the box some time; a message will pop up saying that the job is done.
 
What exactly does 'it does not work' mean?
You have to initialise the HDD. After starting the initialisation process you must allow the box some time; a message will pop up saying that the job is done.

The error message I get when trying to intialise the drive is, as follows:

"Error: writing inode tables: 0/7453..... Plus many other codes...................done.
Creating journal (32768blocks): mkfs ext 4. Attempt to write block to filesystem resulted in short write while trying to create journal"

I have waited long time when starting intialisation process but only error box is coming. How can I fix this?
 
The error message I get when trying to intialise the drive is, as follows:

"Error: writing inode tables: 0/7453..... Plus many other codes...................done.
Creating journal (32768blocks): mkfs ext 4. Attempt to write block to filesystem resulted in short write while trying to create journal"

I have waited long time when starting intialisation process but only error box is coming. How can I fix this?

Have you any other box you can format the drive on?
 
Have you any other box you can format the drive on?

Unfortunetly, I only have the one box.

If I were to remove the drive and replace with another new 1tb hard drive and then try to intialise in the Vix image (I have updated to V3.0, 382) do you think that would work?
 

OpenViX Feeds Status

Back
Top