Superb quality and spec AB-Com PULSe 4K SE. Crazy offer! Only £99! FREE UK DELIVERY! 4K UHD, Enigma 2, Multiboot 4 images & more!...
Superb quality and spec AB-Com PULSe 4K Rev II Twin Satellite tuner only £149! FREE UK DELIVERY! 4K UHD, Enigma 2, SATA HDD facility, Multiboot 4 images & more!...

Channels Importer

I'm finding I have the same problem with this set up as I had with RSCC.

The serving box (my VU+Duo2) will randomly wake up from standby into the tuner that's being used by the client box.

This means I lose my connection.

Is there any way to keep the server in standby to stop this happening?
 
I'm finding I have the same problem with this set up as I had with RSCC.

The serving box (my VU+Duo2) will randomly wake up from standby into the tuner that's being used by the client box.

This means I lose my connection.

Is there any way to keep the server in standby to stop this happening?
This is nothing to do with the plugin. Please start your own thread.
 
Hi. How can you say it is nothing to do with the plugin as it only wakes up when using the client. If both are in Stby it doesn't wake up.
 
Hi. How can you say it is nothing to do with the plugin as it only wakes up when using the client. If both are in Stby it doesn't wake up.
Sorry, you lost me. You haven't posted in this thread before so please fill in the missing details.
 
Hi Guys. Does this work on multiple boxes or can you only have on box running off on server box? I wanted to have my main box in the living room, then run the fall back tuner in my kitchen on one box and in the bedroom on another box
 
Depends how many free tuners your main box has. The more tuners the better. This is where the FBC tuner capable boxes come in handy.


Sent from my iPhone using Tapatalk
 
Yep, as above, as long as you have sufficient tuner on the server box to cover the demand you can have as many clients as you like. And set an inactivity timer on all the clients so they don't waste tuners on the server.
 
Great thanks. I have a Ultimo 4k with FBC cable tuner so should be ok on that front :thumbsup:
 
Hi. Go this working now and its great!!! Does anyone know if you are able to stream your recording form your main box to the client box?
 
Hi. Go this working now and its great!!! Does anyone know if you are able to stream your recording form your main box to the client box?
Not currently. So best option is a network mount to the server.

I think in the future we could get a directory listing from the remote box and create a bouquet of recordings.
 
Hi,
I have a small problem with this plugin on current ViX with up to now two VUs (Solo4K and Duo2):

< 228.478> [LCD4linux] Done Worker Pic 0
< 228.660> [ChannelsImporter] Downloading remote file 'userbouquet.adulttv.tv'
< 228.820> [ChannelsImporter] Downloading remote file 'userbouquet.sammlung.tv'
< 228.986> [ChannelsImporter] Downloading remote file 'userbouquet.adulttv.tv'
< 229.146> [ChannelsImporter] Downloading remote file 'userbouquet.deutschland.radio'
< 229.309> [ChannelsImporter] Downloading remote file 'userbouquet.oldies_klassik.radio'
< 229.474> [ChannelsImporter] Downloading remote file 'userbouquet.rock___pop.radio'
< 229.663> [ChannelsImporter] Downloading remote file 'userbouquet.iptv_deutsche_partymusik.radio'
< 229.817> [ChannelsImporter] Downloading remote file 'userbouquet.favourites.radio'
< 229.979> [ChannelsImporter] Downloading remote file 'lamedb'
< 230.257> [ChannelsImporter] Checking for alternatives
< 230.356> [ChannelsImporter] Removing current channel list...
< 230.416> [ChannelsImporter] Loading new channel list...
< 230.651> [ChannelsImporter] Download from remote failed. [Failure instance: Traceback: <type 'exceptions.IOError'>: [Errno 2] No such file or directory: '/tmp/userbouquet.adulttv.tv'
/usr/lib/python2.7/site-packages/twisted/internet/defer.py:653:_runCallbacks
/usr/lib/enigma2/python/Plugins/SystemPlugins/ChannelsImporter/FTPDownloader.py:84:ftpFinish
/usr/lib/python2.7/site-packages/twisted/internet/defer.py:459:callback
/usr/lib/python2.7/site-packages/twisted/internet/defer.py:567:_startRunCallbacks
--- <exception caught here> ---
/usr/lib/python2.7/site-packages/twisted/internet/defer.py:653:_runCallbacks
/usr/lib/enigma2/python/Plugins/SystemPlugins/ChannelsImporter/ChannelsImporter.py:144:readBouquetsCallback
/usr/lib/enigma2/python/Plugins/SystemPlugins/ChannelsImporter/ChannelsImporter.py:172:processFiles
/usr/lib/enigma2/python/Plugins/SystemPlugins/ChannelsImporter/ChannelsImporter.py:273:copyFile
/usr/lib/python2.7/shutil.py:130:copy2
/usr/lib/python2.7/shutil.py:82:copyfile

Any idea?

ciao
 
No idea what that is. It is in the Python twisted code, not the plugin.

Can you try in client mode to see if you get a similar problem? Doesn't use the twisted code so might be easier to debug.
 
Hi,
what do you mean with client mode? This error appeared on 3 different client boxes (Solo2, Solo4K and Duo2) server is my Ultimo4K.

Because it has something to do with copying and it says that '/tmp/userbouquet.adulttv.tv' is not there I commented out the deleting of the temporary files and to be save put a Try/Except around copyFile and now all of my 4 client were running like they should but I will keep an eye on it.

After I commented out the deletion of the temporary files I took a look and the "missing" file was really there. Not sure why Python complained.

ciao
 
I mean the error occurred with the Channels Importer plugin. "Client Mode (OpenViX)" available from the NimSelection screen on the yellow button doesn't use Twisted. Something weird must be going on in Twisted. Must be trying to delete the file multiple times, or something like that.
 
Hi,
I think also the yellow button had this error but I will try again.

ciao
 
Hi abu,
I rename and recheck. This is easily done.

ciao
 
Hi,
I think I found the reason. I used the plugin IPTVstreamlink from pcd and this generates a bouquets.tv like this:
#SERVICE 1:7:1:0:0:0:0:0:0:0:FROM BOUQUET "userbouquet.UK-LIVE-TV.tv" ORDER BY bouquet
=#SERVICE 1:7:1:0:0:0:0:0:0:0:FROM BOUQUET "userbouquet.UK LIVE TV.tv" ORDER BY bouquet

I think will be copied twice and then
1. copy userbouquet.UK-LIVE-TV.tv
2 remove userbouquet.UK-LIVE-TV.tv
3. copy userbouquet.UK-LIVE-TV.tv and now io fails as this was already deleted by step 2.

ciao
 
So we need to check the file exists before trying to delete.
 

OpenViX Feeds Status

Back
Top