Superb quality and spec AB-Com PULSe 4K SE. Crazy offer! Only £99! FREE UK DELIVERY! 4K UHD, Enigma 2, Multiboot 4 images & more!...
Superb quality and spec AB-Com PULSe 4K Rev II Twin Satellite tuner only £149! FREE UK DELIVERY! 4K UHD, Enigma 2, SATA HDD facility, Multiboot 4 images & more!...

[SF8008] Open ViX Downloads Before v6.2 - Any Links?

I noticed that some recordings had failed last night due to /media/hdd not being writeable. Mount Manager showed that the drive was marked as read only.
I did a full reboot and the drive won't mount at all now. I haven't had chance to investigate further yet. OpenViX 6.2.010 (2022-09-05) dev build on a GigaBlue UHD UE 4K.
My logs are set to save to hdd but I noticed there is a crash log in /home/root/.

View attachment 64268

I think it is probably generated because I have no hdd rather than showing why it was set to R/O

Dmsg shows error:
3.419268] scsi 2:0:0:0: Direct-Access USB SanDisk 3.2Gen1 1.00 PQ: 0 ANSI: 6
<5>[ 3.428685] sd 2:0:0:0: Attached scsi generic sg0 type 0
<5>[ 3.434637] sd 2:0:0:0: [sda] 240353280 512-byte logical blocks: (123 GB/115 GiB)
<5>[ 3.447080] sd 2:0:0:0: [sda] Write Protect is on
<7>[ 3.451834] sd 2:0:0:0: [sda] Mode Sense: 43 00 80 00
<5>[ 3.459208] sd 2:0:0:0: [sda] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
<6>[ 3.498232] sda: sda1
<5>[ 3.502689] sd 2:0:0:0: [sda] Attached SCSI removable disk
<5>[ 3.556820] random: nonblocking pool is initialized
<6>[ 3.871703] EXT4-fs (mmcblk0p5): re-mounted. Opts: nodelalloc,data=journal
<6>[ 4.167945] EXT4-fs (sda1): INFO: recovery required on readonly filesystem
<3>[ 4.174878] EXT4-fs (sda1): write access unavailable, cannot proceed
<3>[ 4.194909] EXT3-fs (sda1): error: couldn't mount because of unsupported optional features (2c0)
<3>[ 4.206148] EXT2-fs (sda1): error: couldn't mount because of unsupported optional features (2c4)
<4>[ 4.221346] UDF-fs: warning (device sda1): udf_fill_super: No partition found (2)
 
I'll try another hdd later on. I added my post to this thread because nekrub2's hdd had suddenly become R/O as well. Just wondered if it was related.
 
MP3Browser crash read only?

I removed the USB HDD and plugged it into my laptop on the windows 7 partition. Indeed the directory mp3browser and its underlying sub-directories cache and db had the read only attribute. so I set them to read and write and attached the stick back to the box. When trying to update the MP3Browser database the box crashed again. This time I could read one error, saying
FAT-fs (sda1): error, fat_free_clusters: deleting FAT entry beyond EOF.
FAT-fs (sda1): Filesystem has been set read-only.

Could it be that I have a buggy stick and as soon as openvix detects this it sets it read-only?

I attach the crash log.
 

Attachments

FAT-fs (sda1): error, fat_free_clusters: deleting FAT entry beyond EOF.
FAT-fs (sda1): Filesystem has been set read-only.

Could it be that I have a buggy stick and as soon as openvix detects this it sets it read-only?

I attach the crash log.
If this is a FAT/FAT32 formatted USB then I would plug this into a Windows device and do a full chkdisk (not quick).

It's talking about deleting File Allocation Table entry beyond the End of File so this doesn't sound promising
 
Dear all
I could fix my problem. 1. I made a chkdsk under windows (after copying the whole content on the HD). With this a big part of the problem was solved. When trying to import again it crashed again but this time I could read out that it had something to do with the character sets (windows versus UTF-8). And indeed, under Linux I could see file names that were broken because they had special characters in, which are different in the two system. After manual editing the files over ftp I did a now mp3browser update and it worked. 127 songs were imported.

Just for your information I attach the crash log related to the file names.

nekrub2
 

Attachments

Dear all
I could fix my problem. 1. I made a chkdsk under windows (after copying the whole content on the HD). With this a big part of the problem was solved. When trying to import again it crashed again but this time I could read out that it had something to do with the character sets (windows versus UTF-8). And indeed, under Linux I could see file names that were broken because they had special characters in, which are different in the two system. After manual editing the files over ftp I did a now mp3browser update and it worked. 127 songs were imported.

Just for your information I attach the crash log related to the file names.

nekrub2

Thanks. Down with covid will look when recovered.
 
Hi Twol
Wish you a fast and complete recovery. Take your time and do not force yourself too much in the beginning.
nekrub2
 
The skin on my box is VIXBMC_1080_Confluence. On TV or Radio I do not have a problems with cut-offs or not completely displayed characters. I think this is plugin specific.
 

OpenViX Feeds Status

Back
Top