Superb quality and spec AB-Com PULSe 4K SE. Crazy offer! Only £129! FREE UK DELIVERY! 4K UHD, Enigma 2, Multiboot 4 images & more!...
Superb quality and spec AB-Com PULSe 4K Rev II Twin Satellite tuner only £179! FREE UK DELIVERY! 4K UHD, Enigma 2, SATA HDD facility, Multiboot 4 images & more!...

[VU+ Duo] restoring from a tar.gz file via telnet / SSH

  • Thread starter Thread starter acseuser
  • Start date Start date
A

acseuser

Guest
I added some plugins and other stuff, but after that (I think) the box is continuously rebooting.

AS a short-term fix, I'd like to restore to a previously-saved .tar.gz backup. But since the box is rebooting so often/quickly after boot up, I can't do it via the GUI!

I've got a telnet (and SSH) login; how can I restore the backup? Is that just settings? Do I need to rollback the FW version as well, even though it was working perfectly (I know, if it ain't broke, don't mess with it) before.

Thanks,

SR.
 
Sounds like it's stuck in an E2 bootloop.
Have a look in /home/root/logs/ for crashlogs being generated & upload one here.
 
Sure 'nuf; here is one -

<?xml version="1.0" encoding="utf-8"?>
<openvix>
<enigma2>
<crashdate>Wed Aug 13 22:04:50 2014</crashdate>
<compiledate>Jul 29 2014</compiledate>
<contactemail>[email protected]</contactemail>
<!-- Please email this crashlog to above address -->
<skin>ViX-Night-HD/skin.xml</skin>
<sourcedate>2014-07-29</sourcedate>
<version>3.0.0</version>
</enigma2>
<image>
<stbmodel>duo</stbmodel>
<kernelversion>
<![CDATA[
Linux vuduo 3.1.1 #1 SMP Sun Jul 6 12:47:51 BST 2014 mips GNU/Linux
]]>
</kernelversion>
<kernelcmdline>bmem=112M ubi.mtd=0 root=ubi0:rootfs rootfstype=ubifs rw console=ttyS0,115200n8 rootflags=sync</kernelcmdline>
<nimsockets>NIM Socket 0:</nimsockets>
<imageversion>
<!-- No such file or directory -->
</imageversion>
<imageissue>
<![CDATA[
Welcome to OpenViX for %h
openvix Apollo %h

]]>
</imageissue>
</image>
<software>
<enigma2software>
<![CDATA[
Collected errors:
* opkg_conf_load: Could not lock /var/lib/opkg/lock: Resource temporarily unavailable.
]]>
</enigma2software>
<vuplussoftware>
<![CDATA[
Collected errors:
* opkg_conf_load: Could not lock /var/lib/opkg/lock: Resource temporarily unavailable.
]]>
</vuplussoftware>
<gstreamersoftware>
<![CDATA[
Collected errors:
* opkg_conf_load: Could not lock /var/lib/opkg/lock: Resource temporarily unavailable.
]]>
</gstreamersoftware>
</software>
<crashlogs>
<enigma2crashlog>
<![CDATA[
+ (1) Background File Eraser
+ (5) Tuxtxt
+ (8) graphics acceleration manager
+ (9) GFBDC
12150k video mem
- double buffering available!
4050kB available for acceleration surfaces.
resolution: 1280 x 720 x 32 (stride: 5760)
+ (9) gLCDDC
found OLED display!
lcd buffer 0x7c4230 8448 bytes, stride 132
LCD resolution: 132 x 64 x 8 (stride: 132)
+ (9) Font Render Class
[FONT] initializing lib...
[FONT] loading fonts...
[FONT] Intializing font cache, using max. 4MB...
+ (10) gRC
RC thread created successfully
+ (15) eWindowStyleManager
+ (20) DVB-CI UI
+ (20) UHF Modulator
couldnt open /dev/rfmod0!!!!
+ (20) RC Input layer
+ (20) misc options
+ (20) AVSwitch Driver
+ (21) input device driver
Input device "dreambox advanced remote control (native)" is a mouse
Found 1 input devices.
+ (22) Hdmi CEC driver
eHdmiCEC: detected physical address change: 1000 --> FFFF
eHdmiCEC: send message 84 FF FF 03
+ (30) eActionMap
+ (35) CI Slots
scanning for common interfaces..
CI Slot 0 setSource(0)
CI Slot 1 setSource(0)
eDVBCIInterfaces->setInputSource(0, 0)
eDVBCIInterfaces->setInputSource(1, 1)
cannot open /proc/stb/tsmux/input2
cannot open /proc/stb/tsmux/input3
done, found 2 common interface slots
+ (35) CA handler
+ (40) eServiceCenter
settings instance.
+ (41) eServiceFactoryDVD
+ (41) eServiceFactoryHDMI
+ (41) eServiceFactoryM2TS
+ (41) eServiceFactoryMP3
+ (41) eServiceFactoryFS
+ (41) eServiceFactoryDVB
+ (41) Stream server
reached rl 70
---- opening lame channel db
reading services (version 4)
loaded 82 channels/transponders and 975 services
scanning for frontends..
opening frontend 0
close frontend 0
opening frontend 1
close frontend 1
found 1 adapter, 2 frontends(2 sim) and 5 demux, boxtype 4
Use valid Linux Time :) (RTC?)
[EPGC] Initialized EPGCache (wait for setCacheFile call now)
Loading spinners...
[ePNG] couldn't open /usr/share/enigma2/spinner/wait20.png
found 19 spinner!
setIoPrio best-effort level 3 ok
couldn't open /proc/stb/misc/12V_output
[Harddisk] enumerating block devices...
new Harddisk sda -> /dev/sda -> /dev/sda
new Harddisk sdb -> /dev/sdb -> /dev/sdb
[Harddisk] enumerating network mounts...
Reading satellites.xml
main thread is non-idle! display spinner!
removing internal link on frontend id 1
sec config cleared
setSlotInfo for dvb frontend 0 to slotid 0, descr BCM7335 DVB-S2 NIM (internal), need rotorworkaround No, enabled Yes, DVB-S2 Yes
setSlotInfo for dvb frontend 1 to slotid 1, descr BCM7335 DVB-S2 NIM (internal), need rotorworkaround No, enabled Yes, DVB-S2 Yes
slot: 0 configmode: equal
slot: 1 configmode: simple
diseqcmode: single
sec config completed
[Time By]: Transponder
[EPGC] time updated.. but cache file not set yet.. dont start epg!!
[Ipkg] Added to OPKG destinations: /
[FONT] adding font /usr/share/fonts/Roboto-Bold.ttf...OK (Regular)
[FONT] adding font /usr/share/fonts/Roboto-BoldItalic.ttf...OK (Italic)
[FONT] adding font /usr/share/fonts/Roboto-Black.ttf...OK (Bold)
[FONT] adding font /usr/share/fonts/Roboto-BlackItalic.ttf...OK (Boldit)
[FONT] adding font /usr/share/fonts/nmsbd.ttf...OK (Subtitlefont)
[FONT] adding font /usr/share/fonts/lcd.ttf...OK (LCD)
[FONT] adding font /usr/share/fonts/ae_AlMateen.ttf...OK (Replacement)
[FONT] adding font /usr/share/fonts/tuxtxt.ttf...OK (Console)
[SKIN] loading include: /usr/share/enigma2/ViX-Common/CommonSkin.xml
[FONT] adding font /usr/share/fonts/nmsbd.ttf...OK (Subs)
[FONT] adding font /usr/share/fonts/nmsbd.ttf...OK (FdLcD)
[iInputDevices] getInputDevices <ERROR: ioctl(EVIOCGNAME): [Errno 25] Inappropriate ioctl for device >
[iInputDevices] getInputDevices <ERROR: ioctl(EVIOCGNAME): [Errno 25] Inappropriate ioctl for device >
Activating keymap: Default (US)
Activating language English (UK)
[VideoMode] setting aspect: 16:9
[VideoMode] setting wss: auto
[VideoMode] setting policy: panscan
[VideoMode] setting policy2: letterbox
[VideoMode] setting scaler_sharpness to: 0000000D
[VideoMode] setMode - port: Scart, mode: PAL, rate: 50Hz
Renumbering...
[EPGC Loads] Poller enabled.
[EPGC Save] Poller enabled.
[EPGC] setCacheFile read/write epg data from/to '/media/usb/epg.dat'
[EPGC] time updated.. start EPG Mainloop
setLCDBrightness 25
setLCDBrightness 127
Setting OSD position: 50 638 28 523
Setting OSD alpha: 255
Setting 3D mode: auto
Setting 3D depth: 50
[EPGC Save] Poller enabled.
[EPGC Loads] Poller enabled.
FIXME: request for unknown slot
FIXME: request for unknown slot
[EPGC] 40124 events read from /media/usb/epg.dat
Plugin Extensions/WebAdmin failed to load: No module named Screenpage
Traceback (most recent call last):
File "/usr/lib/enigma2/python/Components/PluginComponent.py", line 53, in readPluginList
File "/usr/lib/enigma2/python/Tools/Import.py", line 2, in my_import
File "/usr/lib/enigma2/python/Plugins/Extensions/WebAdmin/plugin.py", line 4, in <module>
ImportError: No module named Screenpage
[VLC] Checking for buildin servicets ... no
[VLC] Checking for existing and usable servicets.so ... yes
[VLC] fallback to default translation for A video streaming solution based on VLC
Plugin Extensions/WebInterface failed to load: No module named plugin
IPTV-List-Updater set language to en
[XMLTVImport] autostart (0) occured at 1407963886.16
[AutoTimer] Auto Poll Enabled
[SoftcamManager] AutoStart Enabled
[CI_Assignment] activating ci configs:
[CI_Activate] FOUND 2 CI Slots
[CI_Activate_Config_CI0] no config file found
[CI_Activate_Config_CI0] error parsing xml...
[CI_Activate_Config_CI1] no config file found
[CI_Activate_Config_CI1] error parsing xml...
starting hotplug handler
Removed /tmp/.sock.hbbtv.url
[SKIN] Parsing embedded skin <embedded-in-'HbbTVHelper'>
[CrossEPG_Auto] AutoStart Enabled
[CrossEPG_Auto] Schedule Enabled at Wed 13 Aug 2014 22:04:46 IST
Send OK!! : OP_HBBTV_FULLSCREEN
[CrossEPG_Auto] Time set to Thu 14 Aug 2014 01:00:00 IST (now=Wed 13 Aug 2014 22:04:46 IST)
[ImageManager] AutoStart Enabled
[ImageManager] Backup Schedule Disabled at (now=Wed 13 Aug 2014 22:04:46 IST)
[BackupManager] AutoStart Enabled
[BackupManager] Backup Schedule Disabled at (now=Wed 13 Aug 2014 22:04:46 IST)
[AutoBouquetsMaker] AutoStart Enabled
[AutoBouquetsMaker] AutoBouquetsMaker Schedule Enabled at Wed 13 Aug 2014 22:04:46 IST
[AutoBouquetsMaker] AutoBouquetsMaker Time set to Thu 14 Aug 2014 01:00:00 IST (now=Wed 13 Aug 2014 22:04:46 IST)
[AutomaticVolumeAdjustment] Starting AutomaticVolumeAdjustment...
[AutomaticVolumeAdjustmentConfig] Loading config file...
[AutomaticVolumeAdjustmentConfig] Loaded 0 entries from config file...
[AutomaticVolumeAdjustment] initialize config values...
Setvolume: 100 100 (raw)
Setvolume: 0 0 (-1db)
[XMLTVImport] autostart (0) occured at 1407963886.5
[XMLTVImport] WakeUpTime now set to -1 (now=1407963886)
[Errno 6] No such device or address: '/tmp/.sock.hbbtv.cmd'
No found pipe!!
warning, skin is missing element state in <class 'Screens.PVRState.TimeshiftState'>
RemovePopup, id = ZapError
[Skin] Attribute not implemented: alphatest value: blend
setValue 55
Setvolume: 55 55 (raw)
Setvolume: 29 29 (-1db)
[LogManager] Trim Poll Started
[LogManager] Trash Poll Started
[LogManager] probing folders
[LogManager] found following log's: ['/media/hdd/logs', '/home/root/logs']
[LogManager] looking in: /media/hdd/logs
[LogManager] looking in: /home/root/logs
[LogManager] /home/root/logs: bytesToRemove -10419206
[NTP]: setting E2 time: 1407963889.33
playing 1:0:1:D37C:81C:2:11A0000:0:0:0:
RemovePopup, id = ZapError
allocate channel.. 081c:0002
opening frontend 0
(0)tune
RotorCmd ffffffff, lastRotorCmd ffffffff
prepare_sat System 0 Freq 12551500 Pol 1 SR 22000000 INV 2 FEC 4 orbpos 282 system 0 modulation 1 pilot 2, rolloff 0
tuning to 1951 mhz
OURSTATE: tuning
allocate Channel: res 0
[eDVBCIInterfaces] addPMTHandler 1:0:1:D37C:81C:2:11A0000:0:0:0:
allocate demux
poll: unhandled POLLERR/HUP/NVAL for fd 34(16)
poll: unhandled POLLERR/HUP/NVAL for fd 36(16)
poll: unhandled POLLERR/HUP/NVAL for fd 41(16)
job Components.Task.Job name=LogManager #tasks=1 completed with [] in None
[SEC] set static current limiting
0.0.0.0
192.168
executing opkg --add-dest /:/ update
ER plugin not found
Traceback (most recent call last):
File "/usr/lib/enigma2/python/Tools/BoundFunction.py", line 9, in __call__
File "/usr/lib/enigma2/python/Components/Console.py", line 58, in finishedCB
File "/usr/lib/enigma2/python/Components/Network.py", line 131, in routeFinished
File "/usr/lib/enigma2/python/Components/Network.py", line 228, in loadNetworkConfig
File "/usr/lib/enigma2/python/Components/Network.py", line 685, in msgPlugins
File "/home/vix2/oe-alliance/builds/openvix/tmp/work/vuduo-oe-linux/enigma2-plugin-extensions-openwebif/enigma2-plugin-extensions-openwebif-1+gitAUTOINC+c73d2eeba4-r0/git/plugin/plugin.py", line 146, in IfUpIfDown
File "/home/vix2/oe-alliance/builds/openvix/tmp/work/vuduo-oe-linux/enigma2-plugin-extensions-openwebif/enigma2-plugin-extensions-openwebif-1+gitAUTOINC+c73d2eeba4-r0/git/plugin/httpserver.py", line 126, in HttpdStart
File "/home/vix2/oe-alliance/builds/openvix/tmp/work/vuduo-oe-linux/enigma2-plugin-extensions-openwebif/enigma2-plugin-extensions-openwebif-1+gitAUTOINC+c73d2eeba4-r0/git/plugin/httpserver.py", line 111, in buildRootTree
File "/usr/lib/enigma2/python/Plugins/Extensions/WebInterface/WebChilds/External/EPGRefresh.py", line 2, in <module>
ImportError: No module named EPGRefresh.EPGRefreshResource
(PyObject_CallObject(<Tools.BoundFunction.boundFunction instance at 0x1db4aa8>,(0,)) failed)
]]>
</enigma2crashlog>
</crashlogs>
</openvix>
 
OK, so in the absense of a solution to the problem, how do I recover the box - without use of the GUI - hopefully using the backup created by image manager??
 
I am sorry that no one was able to help you even after you went to the trouble of uploading a crash log.

The latest Apollo 025 image will require a complete re-install from scratch, which you will want do either now or some time in the future. I suggest you do a fresh USB install of Apollo 025 from scratch and then set everything up again from the beginning.
 
Collected errors:
* opkg_conf_load: Could not lock /var/lib/opkg/lock: Resource temporarily unavailable.
]=]=>
</enigma2software>
<vuplussoftware>
<=!=[=C=D=A=T=A=[
Collected errors:
* opkg_conf_load: Could not lock /var/lib/opkg/lock: Resource temporarily unavailable.
]=]=>
</vuplussoftware>
<gstreamersoftware>
<=!=[=C=D=A=T=A=[
Collected errors:
* opkg_conf_load: Could not lock /var/lib/opkg/lock: Resource temporarily unavailable.

Try to FTP into the receiver and delete the file in /var/lib/opkg/ then reboot the receiver.

but as said above, build 025 will require a full reflash WITHOUT restore any way.
 
Good thanks; sorry for late reply,

So, I re-flashed to 026 before reading this thread; then did a restore of settings; there doesn't seem to be any implications... yet. ALL very easy - credit to your work. I did wonder whether it was possible to do this from CLI without requiring a USB stick, but it's easy without.

Mebbe I'll re-flash again, and do a fresh setup, re-downloading the plugins etc... tonight, if it's necessary
 
Good thanks; sorry for late reply,

So, I re-flashed to 026 before reading this thread; then did a restore of settings; there doesn't seem to be any implications... yet. ALL very easy - credit to your work. I did wonder whether it was possible to do this from CLI without requiring a USB stick, but it's easy without.

Mebbe I'll re-flash again, and do a fresh setup, re-downloading the plugins etc... tonight, if it's necessary

I would recomend you do maybe not be a problem at the moment but sure to give you trouble at sometime
 
Good thanks; sorry for late reply,

So, I re-flashed to 026 before reading this thread; then did a restore of settings; there doesn't seem to be any implications... yet. ALL very easy - credit to your work. I did wonder whether it was possible to do this from CLI without requiring a USB stick, but it's easy without.

Mebbe I'll re-flash again, and do a fresh setup, re-downloading the plugins etc... tonight, if it's necessary

When you use a settings backup in ViX it connects to the feeds and downloads the plugins you had previously installed (which is why it won't work if you don't have a internet connection).

Because of the difference in OE cores between Apollo 024/025 using a settings backup will download plugins built for the wrong OE core and in the case of some machines for the wrong Linux kernel. This can cause numerous as yet unknown issues for your hardware and image, which is why we recommended a fresh flash without using a backup.

Now the decision is ultimately yours but we issue our advice for a reason and not lightly.


Sent from my iPad Air using Tapatalk HD
 
OH, I understand the reasons behind your requirement; indeed on a rainy afternoon last week, I did a re-flash and re-config. as 026.

Can't say I saw anything work that wasn't before, or anything not work that was :-)

I have taken an image backup, as a precaution.

Thanks for your help,

Simon R
 

OpenViX Feeds Status

Back
Top