Here is just one example of 2004 used in an important e2 file.
https://github.com/OpenViX/enigma2/blob/Dev/lib/dvb/dvbtime.cpp#L315-L319
https://github.com/OpenViX/enigma2/blob/Dev/lib/dvb/dvbtime.cpp#L315-L319
Dec 30 10:38:13 gbquad4k daemon.notice ntpdate[*1822*]: step time server 85.199.214.101 offset 202264.724341 sec
Jan 1 18:49:22 gbquad4k daemon.notice ntpdate[*1824*]: step time server 85.199.214.101 offset 202264.725832 sec
Dec 30 15:30:07 duo2 daemon.notice ntpdate[13240]: adjust time server 192.168.75.1 offset -0.007456 sec
Dec 30 15:30:07 duo2 daemon.notice stb-hwclock: Current system time has been written into FP pseudo RTC.
Yes.Will these latest changes hopefully solve potential issue with likes of certs in OpenVPN that was mentioned in an earlier post of yours?
openvpn said:Wed Oct 15 03:03:44 2014 TLS: Initial packet from [AF_INET6]2001:db8:4063:dead:beef:1fff:fe12:3456:53667, sid=b0b81bb4 36d599a0
Wed Oct 15 03:03:46 2014 VERIFY ERROR: depth=1, error=certificate is not yet valid: C=GDR, ST=SomeState, L=Somewhere, O=mocowolf, OU=CA Cert, CN=mocowolf CA, name=Root CA, [email protected]
Wed Oct 15 03:03:46 2014 OpenSSL: error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed
rclone said:root@quadbox ~ # mount -a
root@quadbox ~ # 2014/10/15 03:06:01 Failed to create file system for "ACD:": failed to get endpoints: Get https://drive.amazonaws.com/drive/v1/account/endpoint: x509: certificate has expired or is not yet valid
But all that seems to have happened is that you've replaced one set of problems, which have always been there, with a different set of problems, which have never been problems before.It's meant to address errors like these:
But it won't.It's meant to address errors like these:
No, vice versa:Also, the check_online()function in the script is pinging www.google.com. That means it has to resolve www.google.com (meaning it has network access) before it can do the ping, which rather means the ping is pointless.
I'd suggest using the IP address of Googles nameservers instead (8.8.8.8 and 2001:4860:4860::8888).
OK, but if name resolution is failing because the network isn't up isn't there a possibility that the loop over 5 attempts will actually get run very quickly (since ping won't be running with its 4s timeout)?As the time servers are usually also specified as an URL (pool.ntp.org), name resolution has to work too for it to work.
udhcpc-Scripts set the routing first, then DNS, so there is a tiny moment at which the interface is already up (IPs are routable) but names can not be resolved yet.

OK, but if name resolution is failing because the network isn't up isn't there a possibility that the loop over 5 attempts will actually get run very quickly (since ping won't be running with its 4s timeout)?
You don't seem to be following the actual bug issue.As the sync is backgrounded, higher values at least shouldn't slow down boot.
Then you would be using the time from the transponders (in enigma2) and, since there is no network interface to bring up then there will be no ntpdate-sync run at boot time.Out of interest. What happens if the box isn't networked at all and is just being used as a stand alone broadcast receiver/PVR?
You don't seem to be following the actual bug issue.
The time sync at boot must not be done in the background!
So your box either syncs twice or never? I can't, at the moment, see how that can happen. But if it is then there must be a way...When I changed back to NTP sync and rebooted after complete power down, then the box was stuck on fake-hwclock.data time.
I now have an ntpdate-sync script which runs ntpdate in the background when called from enigma2, but in the foreground if called when an interface is brought up (i.e. METHOD is set).You don't seem to be following the actual bug issue.
The time sync at boot must not be done in the background!
I now have an ntpdate-sync script which runs ntpdate in the background when called from enigma2, but in the foreground if called when an interface is brought up (i.e. METHOD is set).
The former is needed to ensure that the time is set before services start (the whole point of the original change) and the latter is needed as enigma2 runs it using Console.ePopen(), and the Vix spinner pops up if that doesn't complete in <5s(?), which it usually won't.
This is it:
View attachment 55805
No. It has a check to ensure it isn't being run twice at the same time, but that is only done if the /usr/bin/lockfile-create exists, which it doesn't by default on OpenVix.Iso it should be just ntpdate-sync which is being run and it has supposedly a check to ensure that ntpdate is not run twice.
That's a deliberate design feature, although I forget why.Also, the fact that fake-hwclock.data does not get updated once it has a value into the future is another issue.