birdman
Moderator
The boot process never queries any transponder. The enigma2 start-up does, if you have it configured to use transponder time rather than NTP.If (when) NTP sync failed, then the boot process fell back to transponder t-sync,
There was never fallback, and there isn't now. Although it is possible that it uses transponder time until it gets a time > 01 Jan 2004...(there are no comments in the code to explain any of its logic).Since the changes in December, there is always a plausible date/time stored and I think that is used if you have "sync by NTP" set and it fails. There is no fallback to transponder time in this case.
What has changed is that because fake-hwclock has set the time to something after 01 Jan 2004 the code thinks that it can start processing things that use the current time.
That is not why it was put in place. The reason for it was to have a roughly-valid clock set for certificate validity checking.Using a stored clock time to be used during boot buys us nothing except getting rid of the 1/1/1970 log filenames.
However, since the only use for a certificate is related to network services it should always be possible to set the time accurately using NTP before the services start.
Last edited: