Superb quality and spec AB-Com PULSe 4K SE. Crazy offer! Only £129! FREE UK DELIVERY! 4K UHD, Enigma 2, Multiboot 4 images & more!...
Superb quality and spec AB-Com PULSe 4K Rev II Twin Satellite tuner only £179! FREE UK DELIVERY! 4K UHD, Enigma 2, SATA HDD facility, Multiboot 4 images & more!...

[VU+ Solo2] crash after opening recordings

Yes, I can confirm - just the same by me on my ET5000 and Solo2 ...

Regards
 
got it to work again. Removed all NFS shares and USB stick, reboot ja then mounted NFS&USB back.
Not sure did i do something else :)
I do not have internall HDD.
 
Maybe the mounts were not setup properly?
Or the recording location wasn't (due to that)?

Anyway: fixed for everybody?
 
Maybe the mounts were not setup properly?
Or the recording location wasn't (due to that)?

It was totally Ok, when checked from terminal /hdd and therefor /media/autofs/NAS did show correct directory from NFS share and recordings did work Ok.
I think even "Media scanner" plugin did work and recordings can played from there.
And no problem with Zeus 001 or 002 or any other older OpenViX. Just after 003 update this issue arrived.
 
Same is happening for me. I didnt see this thread til after I have started afresh. My recordings are on an nfs share too.
 
Just updated Zeus 002 -> 003 and now box crash just after i will press recordings, it starts loading recordings list and then BSOD.
Crash logs attached.

View attachment 33238
View attachment 33239

looks like your using unicode folder names, that is not a good idea, can you please check and rename folders if needed.

Code:
TypeError: coercing to Unicode: need string or buffer, NoneType foun


or the file in trash was been used.

please check both reasons.
 
looks like your using unicode folder names, that is not a good idea, can you please check and rename folders if needed.

Code:
TypeError: coercing to Unicode: need string or buffer, NoneType foun

Nope, not using any special, NFS share is left over from Dreambox world since like a decade:
192.168.1.2:/mnt/data/dream/

or the file in trash was been used.

please check both reasons.

Cant say this for 100% sure, as i cannot rememeber that it was used.
It´s very rare to even go to see what´s on the trash. So probably not had happen.

Some clips from the log files, if this give any other hint
Code:
VIDEO_SLOWMOTION(0) - ok
VIDEO_FAST_FORWARD(0) - ok
VIDEO_CONTINUE - ok
AUDIO_CONTINUE - ok
[eDVBCIInterfaces] gotPMT
[VideoMode] setting aspect: 16:9
[VideoMode] setting wss: auto
[VideoMode] setting policy: bestfit
[VideoMode] setting policy2: scale
[Dish] tuning failed
sdt update done!
statfs failed!
executing opkg  --add-dest /media/usb:/media/usb --add-dest /:/ list-upgradable
poll: unhandled POLLERR/HUP/NVAL for fd 47(16)
[EPGC] start caching events(1394900711)
[OnlineVersionCheck] 0 Updates available
poll: unhandled POLLERR/HUP/NVAL for fd 68(16)
VIDEO_GET_EVENT - ok
VIDEO_GET_EVENT - ok
[VideoMode] setting aspect: 16:9
[VideoMode] setting wss: auto
[VideoMode] setting policy: bestfit
[VideoMode] setting policy2: scale
KEY: 393 PVR
KEY: 393 PVR
action ->  InfobarActions showMovies
statfs failed!
[NTP]: setting E2 time: 1394900713.58
poll: unhandled POLLERR/HUP/NVAL for fd 46(16)
PATH: /media/autofs/
path is none
TuxTxt cache cleared
Traceback (most recent call last):
  File "/usr/lib/enigma2/python/Screens/MovieSelection.py", line 1235, in reloadWithDelay
  File "/usr/lib/enigma2/python/Tools/Trashcan.py", line 196, in update
  File "/usr/lib/enigma2/python/Tools/Trashcan.py", line 34, in get_size
  File "/usr/lib/python2.7/os.py", line 276, in walk
TypeError: coercing to Unicode: need string or buffer, NoneType found
(PyObject_CallObject(<bound method MovieSelection.reloadWithDelay of <class 'Screens.MovieSelection.MovieSelection'>>,()) failed)
main thread is non-idle! display spinner!
[EPGC] abort non avail schedule reading
[EPGC] abort non avail schedule other reading
[EPGC] nownext finished(1394900718)
[EPGC] stop caching events(1394900718)
[EPGC] next update in 60 min
KEY: 174 EXIT
action ->  OkCancelActions cancel
statfs failed!
[eDVBCAService] free slot 0 demux 0 for service 1:0:16:1B5B:46:46:E080000:0:0:0:
[eDVBCAService] free service 1:0:16:1B5B:46:46:E080000:0:0:0:
statfs failed!
statfs failed!
decoder state: play, vpid=-1, apid=-1
DEMUX_STOP - pcr - ok
DEMUX_STOP - video - ok
VIDEO_STOP - ok
AUDIO_STOP - ok
DEMUX_STOP - audio - ok
AUDIO_CONTINUE - ok
start release channel timer
KEY: 174 EXIT
[EPGC] event 3f44 not found in epgcache

Code:
[EPGC] event a0eb not found in epgcache
job Components.Task.Job name=Automaattiajastus #tasks=0 completed with [] in None
PATH: /media/autofs/
path is none
TuxTxt cache cleared
TuxTxt cache cleared
TuxTxt: initialized
TuxTxt service started 1838
TuxTxt running thread...(1838)
Traceback (most recent call last):
  File "/usr/lib/enigma2/python/Screens/MovieSelection.py", line 1235, in reloadWithDelay
  File "/usr/lib/enigma2/python/Tools/Trashcan.py", line 196, in update
  File "/usr/lib/enigma2/python/Tools/Trashcan.py", line 34, in get_size
  File "/usr/lib/python2.7/os.py", line 276, in walk
TypeError: coercing to Unicode: need string or buffer, NoneType found
(PyObject_CallObject(<bound method MovieSelection.reloadWithDelay of <class 'Screens.MovieSelection.MovieSelection'>>,()) failed)
main thread is non-idle! display spinner!
KEY: 400 YELLOW
KEY: 400 YELLOW
action ->  ColorActions yellow
ERROR reading PES (fd=63) - Value too large for defined data type
poll: unhandled POLLERR/HUP/NVAL for fd 63(8)
connectionLost? [Failure instance: Traceback (failure with no frames): <class 'twisted.internet.error.ConnectionLost'>: Connection to the other side was lost in a non-clean fashion: Connection lost.
]
dvb time sync disabled... so set RTC now to current linux time! 2014/03/15 18:30
set wakeup time to 2014/03/15 19:25
recordTimerWakeupAuto True
[eDVBCAService] free slot 0 demux 0 for service 1:0:19:B75:3D:46:E080000:0:0:0:
[eDVBCAService] free service 1:0:19:B75:3D:46:E080000:0:0:0:
decoder state: play, vpid=-1, apid=-1
DEMUX_STOP - pcr - ok
DEMUX_STOP - video - ok
VIDEO_STOP - ok
AUDIO_STOP - ok
DEMUX_STOP - audio - ok
AUDIO_CONTINUE - ok
DEMUX_STOP - ttx - ok
start release channel timer
[XMLTVImport] autostart (1) occured at 1394901046.13
[XMLTVImport] Stop
[AutoTimer] No changes in configuration, won't parse
[EPGRefresh] Stopping Timer
 
looks like your using unicode folder names, that is not a good idea, can you please check and rename folders if needed.

Sorry for my certainly silly question:

What does it mean exactly "looks like using unicode folder names"? Refers to the names of the directories?

For example my auto.network:

PHP:
# automatically generated by enigma 2
# do NOT change manually!
Filme_Festplatte_Keller -fstype=nfs,rw,soft,tcp,nolock, 192.168.2.104:/media/hdd/movie
Filme_Festplatte_Studio -fstype=nfs,rw,soft,tcp,nolock, 192.168.2.107:/media/hdd/movie

Is there a problem with the names?

Thank`s.

Regards
 
Hi,
/media/hdd/movie does look ok for you but for computer and STB it might be encoded in unicode. Unicode is a character set specially code so that it also can handle all other languages included asian ones. Is it a PC share? I am not sure how to check the encoding.

ciao
 
It happened again for me too, issue disapears when i just use "Media Scanner" -> Choose correct share -> Recordings all recordings visible and playable and after that
everything back in normal.

1. Tested to open recordings 2 times -> GUI crash
2. Opened recordings via Media Scanner
3. Opened recordings normal way -> success
4. Rebooted Solo2 as a test -> Open opened recordings -> Success again.

Didn´t touch share nor rebooted machine between that. My NFS share running on Ubuntu.
 
Last edited:
vuduo is crashing every time I open the recording list. This happened after adding a CIFS share via autofs. I have deleted the mount and rebooted, but the problem remains.
Have you also adapted the recording path in recordings settings after changing/deleting mounts?
If there is an invalid location set as recording path, you get serious issues.
 
Have you also adapted the recording path in recordings settings after changing/deleting mounts?
If there is an invalid location set as recording path, you get serious issues.

Rob, my recording path was always set to local hdd.

When I created the mount I set an incorrect IP
Entered recordings - mount wasn't there (strange that!)
Edited the mount to correct address - mount successful
Entered recording list - crash

I'm wondering if it has something to do with editing existing mounts, maybe there are some config files that do not get updated? Complete guess.

Anyway, I took an image backup prior to the mount - so fixed the issue by restoring and mounting again. :thumbsup:
 
It happened again for me too, issue disapears when i just use "Media Scanner" -> Choose correct share -> Recordings all recordings visible and playable and after that
everything back in normal.

1. Tested to open recordings 2 times -> GUI crash
2. Opened recordings via Media Scanner
3. Opened recordings normal way -> success
4. Rebooted Solo2 as a test -> Open opened recordings -> Success again.

Didn´t touch share nor rebooted machine between that. My NFS share running on Ubuntu.

Still the same issue. 016 build atm in use. Everytime this will arrive when box is powered down and then back and
using mediascanner once will fix it.

fstab
Code:
rootfs               /                    auto       defaults              1  1
proc                 /proc                proc       defaults              0  0
devpts               /dev/pts             devpts     mode=0620,gid=5       0  0
usbdevfs             /proc/bus/usb        usbdevfs   noauto                0  0
tmpfs                /var/volatile        tmpfs      defaults              0  0
usbfs                /proc/bus/usb        usbfs      defaults              0  0
UUID=F886-6A81	/media/usb	vfat	defaults	0 0

auto.network
Code:
 automounter configuration
NASSI -fstype=nfs,rw,nolock,tcp,rsize=8192,wsize=8192,soft, 192.168.1.2:/mnt/data/dream

automounts.xml
Code:
<?xml version="1.0" ?>
<mountmanager>
<autofs>
 <nfs>
  <mount>
   <active>True</active>
   <hdd_replacement>True</hdd_replacement>
   <ip>192.168.1.2</ip>
   <sharename>NASSI</sharename>
   <sharedir>mnt/data/dream</sharedir>
   <options>rw,nolock,tcp</options>
  </mount>
 </nfs>
</autofs>
</mountmanager>
 
Hello,

unfortunately still the same issue with me:

It happened again for me too, issue disapears when i just use "Media Scanner" -> Choose correct share -> Recordings all recordings visible and playable and after that
everything back in normal.

1. Tested to open recordings 2 times -> GUI crash
2. Opened recordings via Media Scanner
3. Opened recordings normal way -> success

Running now Zeus 18 ...

I also have nfs-shares. My auto.network I already posted above.

Does anyone have an idea what could be the cause or how to eliminate this error?

Regards
 
Good Morning,

Unfortunately I get still a crash when opening the Movie List. :(

The autofs mounts are thereby created right by the System - with ftp I can see the folders/directories and can also open without problems and see the films.

Acutal crashlog from yesterday evening and auto.network file is attached.

Yesterday I then tentatively Open Pli flashed. There, with the same settings no problems ... :confused:

Has really noone an idea what could be the cause and how it can be corrected?

Please help ...

Regards

PHP:
# automatically generated by enigma 2
# do NOT change manually!
Filme_Festplatte_Keller -fstype=nfs,rw,soft,tcp,nolock, 192.168.2.104:/media/hdd/movie
Filme_Festplatte_Studio -fstype=nfs,rw,soft,tcp,nolock, 192.168.2.107:/media/hdd/movie

View attachment enigma2_crash_1396466509.log
 
Last edited:
Hello,

I have found this in a other thread here in the forum:

I tried to mount a network device, and in media player change to this location and playing media files from that location. Mount was a CIFS mount with autofs.
After a restart and going into media player, the device crashed.
The settings file in the etc/enigma2 directory revealed a new entry called last_video_dir (or something like that) - it was set to /media/autofs.

The only way out of the crash was to issue an init 4 command, update the entry to /media/hdd/movie, and then issue init 3 to restart the interface, to avoid the crash.

Is this possibly the solution also for my Problem (unfortunately I'm currently not at home and can not take a look ...)? If yes, this is a permanent solution or not?

As I understand, the error is possibly , that after mount network shares with autofs, the default recording folder is wrongly and automatically changed to "/media/autofs" (instead of "/media/hdd/movie") in "/etc/enigma2/settings" - right?

Can this error not be eliminated from image?

Regards

PS:
Sorry, if I have misunderstood something ...
 
That should not be the case. And it isn't the case for me (using NFS-shares).
But you're the only one who can tell us, after looking at the settings on your box.

Anyway: after adding/changing mounts, it's always wise to make sure that
1- Mounts are set up correct indeed (mounts management)
2- recording path in recordings settings is (still) correct.
 

OpenViX Feeds Status

Back
Top