Don't worry about build warnings.
Just flash the image and use it.
And don't forget to set up your own feeds.
Just flash the image and use it.
And don't forget to set up your own feeds.
The warnings are not resolved - they just belong to packages that aren't being rebuilt on a rebuild, so don't show up.I found that after a successful build it would give about 39 warnings, if you just run it again it's much quicker and a lot of the warnings are resolved.

And don't forget to set up your own feeds.

So in the build directory you find the receiver directory and there is an Image and IPK directory ... e.g. builds/......../tmp/deploy/images and ipk
ipk is where the feeds are situated ...
Thanks twol, so do I move these ipks to safety and point the feeds.conf to them?

So you do also need to have a Web server running there configured to serve the correct locations.so in meta-oe-alliance/meta-oe/conf/distro/openvix I have following line which points to my NAS box and is built into the Image, so when flashed it looks at my feeds.
Yes, good point I have Apache running on my SynologySo you do also need to have a Web server running there configured to serve the correct locations.
Just started to get build failed errors.
Hopefully this is the correct log.View attachment 59437
What's really needed is the log file mentioned in the ERROR: message, namely:I've just had a go at compiling for the Unibox HDE as it's been a while since images were released. It failed on an error - gstreamer1.0-plugins-good_git.bb:do_compile I think this is the right logfile
Is this box just too old to make an image for or is it something I've done wrong?
As an update, I tried again and it failed at a different stage again, so kept restarting the make and after 4 more fails, it actually completed - just got to get around to flashing and setting up now![]()
If you don't do that and you need it then you get an error at the start of the build and nothing useful happens. So unlikely to be the problem here.I guess my question is how much memory do you have on the box and have you done this? -
modify max_user_watches
echo fs.inotify.max_user_watches=524288 | sudo tee -a /etc/sysctl.conf
sysctl -n -w fs.inotify.max_user_watches=524288
echo fs.inotify.max_user_watches=524288 | sudo tee -a /etc/sysctl.conf
sysctl -n -w fs.inotify.max_user_watches=524288